New major release for GD Press Tools Pro includes improvements to debugger and tracker, many updates, updated all jQuery libraries, refactored and updated JavaScript code, some fixes and changes, and plugin drops support for WordPress versions older then 3.3.

GD Press Tools 4.5 Pro is tested with WordPress 3.6, and because of major jQuery update in this WordPress, all JavaScript code in GD Press Tools is refactored and updated. Because of that, plugin requires WordPress 3.3 or newer to work. All jQuery libraries in the plugin are updated to latest available stable versions. Our own gdr2 library is also updated. Plugin is tested with PHP 5.4 and some minor issues are fixed.

Debugger has new panel for displaying log with executed hooks, and tracker is updated to track the hooks execution. Htaccess tweaks from PerishablePress are updated to latest 5G versions. Plugin includes many small fixes and updates, including fixes to some problems with the backup.

Important: GD Press Tools 4.5 Pro drops support for WordPress 3.0, 3.1 and 3.2. Minimum requirements for the plugin is: WordPress 3.3 or newer, PHP 5.2.4 or newer and mySQL 5.0 or newer.

If you have any issues with this new version, please report them in the forums or in the comments here. As for the future releases of GD Press Tools Pro, there will be major changes coming to the plugin organization and more on that will be announced soon.

No votes yet.
Please wait...

About the author

MillaN
MillaN
Dev4Press owner and lead developer

Programmer since the age of 12 and now WordPress developer with more than 8 years of WordPress experience, author of more than 100 plugins and more than 20 themes.

Learn More

GD Press Tools Pro
Collection of various administration, backup, cleanup, debug, events logging, tweaks and other useful tools and addons that can help with everyday tasks and optimization.
GD Press Tools Pro Logo