System Requirements include specific versions for WordPress, PHP, mySQL for all our plugins and themes. Some of our plugins can have additional requirements (PHP extensions, server type, supported and required third party plugins). Due to the nature of the WordPress development, and accelerated release cycles starting with WordPress 3.7, it makes impossible to support old WordPress versions.

So, even if some plugins can work with old WordPress versions, it is not viable for Dev4Press to support all WordPress versions. You can still use plugins with older WordPress versions (where applicable), but support can be provided only for last 5 WordPress official major releases and 1 currently developed release.

WordPress Requirements

Support is provided for WordPress 3.7, 3.8, 3.94.0, 4.1, 4.2 and 4.3 and for all minor releases related to these major versions. If the plugin system requirements state that it will work with older WordPress versions, you can use it that way, but we can’t provide support related to WordPress versions not listed here.

PHP Requirements

Support is provided for PHP 5.2, 5.3, 5.4, 5.5 and 5.6. In some cases there are some incompatibilities with newer versions 5.4, 5.5 and 5.6, so please report these issues so we can fix them.

MySQL Requirements

Support is provided for MySQL 5.0 and newer.