Blog Post

Updated plugins development policy and requirements

With the rapid development tempo PHP and WordPress have, it is impossible to support every version for each version, and based on the usage statistics, development requirements are modified each year.

Next month, PHP 7.3 will be released, and all development and security updates will stop for both PHP 5.6 and 7.0. PHP 5.5 stopped received security updates over two years ago. So, as of today, we are stopping all testing on PHP 5.5, and plugins and addons will be tested with PHP 5.6 and newer, including PHP 7.3 (currently in RC stage). Any PHP version that is not receiving security updates is dangerous to use, and if your hosting is still using such PHP version, make sure you switch to new PHP version as soon as possible, preferably to PHP 7.1 or 7.2.

With WordPress 5.0 to be released later this month, we are stopping testing the plugins and addons with WordPress 4.4. All future major updates for any plugin or theme will require WordPress 4.5 or newer. This change is keeping in line with the policy to test with the latest 6 major WordPress versions. Once WordPress 5.1 is released, WordPress 4.5 will no longer be used for testing.

You can get the information about the development policy and requirements on the Development Policy page.

Please wait...

About the author

Milan Petrovic
Milan Petrovic

Programmer since the age of 12 and WordPress developer since 2008 as freelancer and author of more than 200 plugins and more than 20 themes.

The Newsletter

Leave a Comment

GeneratePress - The perfect lightweight theme for your next project
Grammarly - Number 1 Writing App