A new version of  GD bbPress Attachments is here several updates and fixes, including the fix for the potential stored XSS vulnerability related to saving and display of upload errors.

The plugin requirements are updated, and now minimum supported PHP version is 5.5, WordPress 4.4 and bbPress 2.5. Few translation strings were missing.

As for the security vulnerability, plugin had potential stored XSS vulnerability related to the saving and displaying upload errors. On some UNIX based systems, the file name can contain < and > characters, so the file name can be used as HTML/JS payload. Upload of such file will fail, but, the logged error will contain the original file name, that was printed without escaping. This is very hard vulnerability to deliver, and it would be visible to administrators and uploaders only, but, it was important to fix it as soon as possible. So, upgrade to 2.6 now.

I would like to thank  Luigi Gubello for responsibly disclosing the vulnerability, who will follow-up with an official disclosure in two weeks.

As always, if you notice any problems, please report them in the comments or in the forum.

Please wait...

About the author

MillaN
MillaN
Dev4Press owner and lead developer

Programmer since the age of 12 and now WordPress developer with more than 8 years of WordPress experience, author of more than 100 plugins and more than 20 themes.

Learn More

GD bbPress Attachments
Attachments upload to the topics and replies in bbPress plugin using media library. Control file size and number of files, integration elements and more.
GD bbPress Attachments Logo

Comments

Leave a Reply

Your email address will not be published. Required fields are marked *

Newsletter

Subscribe to get all the latest news and promotions.

Subscribe We will not send you any spam. Newsletters are sent 2 to 4 times every month.