Dev4Press No Script
Blog Post

Plugins Compatibility with WordPress 5.3

WordPress 5.3 was released yesterday, and it includes significant changes to Block Editor (including new blocks), Admin Interface, new theme, PHP 7.4 support, admin email verification and much more.

I am currently in the process of testing the stable version, and I will write a full review of the new WordPress next week. But, for now, important things to know are related to the compatibility with Dev4Press plugins and addons for WordPress.

Improved Block Editor and New blocks in WordPress 5.3
Improved Block Editor and New blocks in WordPress 5.3

And, as usual, the good news is, that all Dev4Press plugins and addons are fully compatible with new WordPress, and so far, we have not found any issues with it.

There are only a few minor things related to the new admin styling for form elements, and it has caused some small misalignment issues with some elements. That affects few plugins, and updates will be released with minor styling changes. Also, some of these issues are currently being worked on by the WordPress core team, so they might be fixed with the WordPress update because many plugins have been affected by the changes.

If you find any issues with the new WordPress, please, open new topics for in the support forum.

Please wait...

About the author

Milan Petrovic
Milan Petrovic

CEO and Lead developer of Dev4Press Web Development company, working with WordPress since 2008, first as a freelancer, later founding own development company. Author of more than 250 plugins and more than 20 themes.

Subscribe to Dev4Press Newsletter

Get the latest announcements, release digests, promotions and exclusive discounts, and general Dev4Press-related news straight into your mailbox.


This form collects your email (optionally your name) for the purpose of sending you newsletters. Check out our Privacy Policy for more information on how we store and manage your data. We will not send you any spam. Newsletters are sent 2 to 4 times every month.

Latest From The Blog

plugins relase corsecurity 2.1

coreSecurity Pro 2.1

coreSecurity Pro version 2.1 brings one big new feature for enhancing user management and adding a powerful control to disable (and later enable) user accounts with a wide range of settings. There are many more important updates, improvements, and tweaks.
reviews important update bbpress 2 6 11

Important update: bbPress 2.6.11

After a long wait, new minor update for bbPress 2.6 is now available, and it is highly recommended to update your website to this latest version of bbPress as soon as possible.
plugins relase gd power search pro 2 7 lite 2 1 upd

GD Power Search Pro 2.7 & Lite 2.1 for bbPress

Both Lite and Pro version of GD Power Search for bbPress have been updated to fix several issues, discovered after testing with bbPress 2.6.11, including a fix for a bug that is present in bbPress plugin itself.

Leave a Comment

WP Rocket - Make WordPress Load Fast in a Few Clicks
SiteGround - Managed WordPress Hosting
0
0
0
0
0
0
0